@@ -117,6 +117,15 @@ config BR2_PACKAGE_QEMU_SDL
comment "Misc. features"
+config BR2_PACKAGE_QEMU_UUID
+ bool "Enable VMs UUID"
+ depends on BR2_PACKAGE_UTIL_LINUX_LIBUUID
+ help
+ Say 'y' here to have QEMU support UUIDs for VMs.
+
+comment "UUID support requires libuuid (from util-linux)"
+ depends on !BR2_PACKAGE_UTIL_LINUX_LIBUUID
+
config BR2_PACKAGE_QEMU_BLOBS
bool "Install binary blobs"
default y
@@ -149,6 +149,13 @@ else
QEMU_OPTS += --disable-sdl
endif
+ifeq ($(BR2_PACKAGE_QEMU_UUID),y)
+QEMU_OPTS += --enable-uuid
+QEMU_DEPENDENCIES += util-linux
+else
+QEMU_OPTS += --disable-uuid
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_BLOBS),)
QEMU_OPTS += --disable-blobs
endif
@@ -239,7 +246,6 @@ define QEMU_CONFIGURE_CMDS
--disable-fdt \
--disable-bluez \
--disable-guest-base \
- --disable-uuid \
--disable-vde \
--disable-linux-aio \
--disable-cap-ng \
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 9 +++++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 16 insertions(+), 1 deletions(-)