@@ -40,4 +40,11 @@ config BR2_PACKAGE_SPICE_GUI
Say 'y' here to enable the Graphical User Interface (GUI)
start dialog.
+config BR2_PACKAGE_SPICE_TUNNEL
+ bool "Enable network redirection"
+ select BR2_PACKAGE_SLIRP
+ help
+ Say 'y' here to enable network redirection, aka tunnelling
+ through a SLIP/SLIRP session.
+
endif # BR2_PACKAGE_SPICE
@@ -22,7 +22,6 @@ SPICE_DEPENDENCIES = \
# We disable everything for now, because the dependency tree can become
# quite deep if we try to enable some features, and I have not tested that.
SPICE_CONF_OPT = \
- --disable-tunnel \
--disable-opengl \
--disable-smartcard \
--disable-automated-tests \
@@ -44,6 +43,13 @@ else
SPICE_CONF_OPT += --disable-gui
endif
+ifeq ($(BR2_PACKAGE_SPICE_TUNNEL),y)
+SPICE_CONF_OPT += --enable-tunnel
+SPICE_DEPENDENCIES += slirp
+else
+SPICE_CONF_OPT += --disable-tunnel
+endif
+
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/spice/Config.in | 7 +++++++ package/spice/spice.mk | 8 +++++++- 2 files changed, 14 insertions(+), 1 deletions(-)