diff mbox

openssl: fix runtime failure on some powerpc variants

Message ID 1354881980-24101-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit 85736773fa06118b3a5a754f5f5bd4190298aecf
Headers show

Commit Message

Gustavo Zacarias Dec. 7, 2012, 12:06 p.m. UTC
OpenSSL's assembly optimizations por PowerPC seem to be broken for at
least 4xx cores.
Thanks go to Jan Schunke for reporting and testing.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/openssl/openssl.mk |    3 +++
 1 files changed, 3 insertions(+), 0 deletions(-)

Comments

Peter Korsgaard Dec. 10, 2012, 9:29 p.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 Gustavo> OpenSSL's assembly optimizations por PowerPC seem to be broken for at
 Gustavo> least 4xx cores.
 Gustavo> Thanks go to Jan Schunke for reporting and testing.

Committed, thanks.
diff mbox

Patch

diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 265a4fb..160df2e 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -38,8 +38,11 @@  endif
 endif
 endif
 ifeq ($(ARCH),powerpc)
+# 4xx cores seem to have trouble with openssl's ASM optimizations
+ifeq ($(BR2_powerpc_401)$(BR2_powerpc_403)$(BR2_powerpc_405)$(BR2_powerpc_405fp)$(BR2_powerpc_440)$(BR2_powerpc_440fp),)
 	OPENSSL_TARGET_ARCH = ppc
 endif
+endif
 ifeq ($(ARCH),x86_64)
 	OPENSSL_TARGET_ARCH = x86_64
 endif