diff mbox

[2/2] jquery-ui-themes: new package

Message ID 1339704133-11220-2-git-send-email-spdawson@gmail.com
State Accepted
Headers show

Commit Message

Simon Dawson June 14, 2012, 8:02 p.m. UTC
From: Simon Dawson <spdawson@gmail.com>

Signed-off-by: Simon Dawson <spdawson@gmail.com>
---
 package/Config.in                            |    1 +
 package/jquery-ui-themes/Config.in           |   21 +++++++++++++++++
 package/jquery-ui-themes/jquery-ui-themes.mk |   31 ++++++++++++++++++++++++++
 3 files changed, 53 insertions(+)
 create mode 100644 package/jquery-ui-themes/Config.in
 create mode 100644 package/jquery-ui-themes/jquery-ui-themes.mk

Comments

Peter Korsgaard May 6, 2013, 10:15 p.m. UTC | #1
>>>>> "spdawson" == spdawson  <spdawson@gmail.com> writes:

 spdawson> From: Simon Dawson <spdawson@gmail.com>
 spdawson> Signed-off-by: Simon Dawson <spdawson@gmail.com>

Committed with minor tweaks, thanks.

 spdawson> ---
 spdawson>  package/Config.in                            |    1 +
 spdawson>  package/jquery-ui-themes/Config.in           |   21 +++++++++++++++++
 spdawson>  package/jquery-ui-themes/jquery-ui-themes.mk |   31 ++++++++++++++++++++++++++
 spdawson>  3 files changed, 53 insertions(+)
 spdawson>  create mode 100644 package/jquery-ui-themes/Config.in
 spdawson>  create mode 100644 package/jquery-ui-themes/jquery-ui-themes.mk

 spdawson> diff --git a/package/Config.in b/package/Config.in
 spdawson> index 2f20617..20d7323 100644
 spdawson> --- a/package/Config.in
 spdawson> +++ b/package/Config.in
 spdawson> @@ -382,6 +382,7 @@ source "package/flot/Config.in"
 spdawson>  source "package/jquery/Config.in"
 spdawson>  source "package/jquery-sparkline/Config.in"
 spdawson>  source "package/jquery-ui/Config.in"
 spdawson> +source "package/jquery-ui-themes/Config.in"
 spdawson>  source "package/jquery-validation/Config.in"
 spdawson>  source "package/jsmin/Config.in"
 spdawson>  endmenu
 spdawson> diff --git a/package/jquery-ui-themes/Config.in b/package/jquery-ui-themes/Config.in
 spdawson> new file mode 100644
 spdawson> index 0000000..49180f9
 spdawson> --- /dev/null
 spdawson> +++ b/package/jquery-ui-themes/Config.in
 spdawson> @@ -0,0 +1,21 @@
 spdawson> +config BR2_PACKAGE_JQUERY_UI_THEMES
 spdawson> +	bool "jQuery UI themes"
 spdawson> +	select BR2_PACKAGE_JQUERY_UI

It imho makes more sense if it depends on JQUERY_UI.

 spdawson> +	help
 spdawson> +	  Themes for jQuery UI.
 spdawson> +
 spdawson> +	  http://jqueryui.com/
 spdawson> +
 spdawson> +config BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH
 spdawson> +	string "Target install path for CSS"
 spdawson> +	default "/var/www/stylesheets"
 spdawson> +	depends on BR2_PACKAGE_JQUERY_UI_THEMES
 spdawson> +	help
 spdawson> +	  Specify a target install path for CSS files
 spdawson> +

Like for jquery-ui, I've dropped this option.

 spdawson> +++ b/package/jquery-ui-themes/jquery-ui-themes.mk
 spdawson> @@ -0,0 +1,31 @@
 spdawson> +#############################################################
 spdawson> +#
 spdawson> +# jquery-ui-themes
 spdawson> +#
 spdawson> +#############################################################
 spdawson> +JQUERY_UI_THEMES_VERSION = 1.8.21
 spdawson> +JQUERY_UI_THEMES_SITE = http://jquery-ui.googlecode.com/files
 spdawson> +JQUERY_UI_THEMES_SOURCE = jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION).zip

It should have jquery-ui in it's _DEPENDENCIES to ensure it get's built
after it and overrides the base template.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 2f20617..20d7323 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -382,6 +382,7 @@  source "package/flot/Config.in"
 source "package/jquery/Config.in"
 source "package/jquery-sparkline/Config.in"
 source "package/jquery-ui/Config.in"
+source "package/jquery-ui-themes/Config.in"
 source "package/jquery-validation/Config.in"
 source "package/jsmin/Config.in"
 endmenu
diff --git a/package/jquery-ui-themes/Config.in b/package/jquery-ui-themes/Config.in
new file mode 100644
index 0000000..49180f9
--- /dev/null
+++ b/package/jquery-ui-themes/Config.in
@@ -0,0 +1,21 @@ 
+config BR2_PACKAGE_JQUERY_UI_THEMES
+	bool "jQuery UI themes"
+	select BR2_PACKAGE_JQUERY_UI
+	help
+	  Themes for jQuery UI.
+
+	  http://jqueryui.com/
+
+config BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH
+	string "Target install path for CSS"
+	default "/var/www/stylesheets"
+	depends on BR2_PACKAGE_JQUERY_UI_THEMES
+	help
+	  Specify a target install path for CSS files
+
+config BR2_PACKAGE_JQUERY_UI_THEMES_THEME
+	string "Name of theme to install"
+	default "base"
+	depends on BR2_PACKAGE_JQUERY_UI_THEMES
+	help
+	  Specify the name of a jQuery UI theme to be installed
diff --git a/package/jquery-ui-themes/jquery-ui-themes.mk b/package/jquery-ui-themes/jquery-ui-themes.mk
new file mode 100644
index 0000000..e193f51
--- /dev/null
+++ b/package/jquery-ui-themes/jquery-ui-themes.mk
@@ -0,0 +1,31 @@ 
+#############################################################
+#
+# jquery-ui-themes
+#
+#############################################################
+JQUERY_UI_THEMES_VERSION = 1.8.21
+JQUERY_UI_THEMES_SITE = http://jquery-ui.googlecode.com/files
+JQUERY_UI_THEMES_SOURCE = jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION).zip
+
+define JQUERY_UI_THEMES_EXTRACT_CMDS
+	unzip -d $(@D) $(DL_DIR)/$(JQUERY_UI_THEMES_SOURCE)
+	mv $(@D)/jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION)/* $(@D)
+	$(RM) -r $(@D)/jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION)
+endef
+
+define JQUERY_UI_THEMES_INSTALL_TARGET_CMDS
+	$(INSTALL) -m 0644 -D \
+		$(@D)/themes/$(BR2_PACKAGE_JQUERY_UI_THEMES_THEME)/jquery-ui.css \
+		$(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/jquery-ui.css
+	$(INSTALL) -d $(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/images
+	cp -a $(@D)/themes/$(BR2_PACKAGE_JQUERY_UI_THEMES_THEME)/images/*.png \
+		$(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/images
+	chmod 0644 $(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/images/*.png
+endef
+
+define JQUERY_UI_THEMES_UNINSTALL_TARGET_CMDS
+	$(RM) $(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/jquery-ui.css
+	$(RM) -r $(TARGET_DIR)/$(BR2_PACKAGE_JQUERY_UI_THEMES_CSS_PATH)/images
+endef
+
+$(eval $(call GENTARGETS))