@@ -56,14 +56,23 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
comment "xorg-xserver is BROKEN on AVR32"
depends on BR2_avr32
+if BR2_PACKAGE_XSERVER_XORG_SERVER
+
config BR2_PACKAGE_XSERVER_XORG_SERVER_NULL_CURSOR
bool "Null root cursor"
- depends on BR2_PACKAGE_XSERVER_XORG_SERVER
help
Don't display root cursor.
config BR2_PACKAGE_XSERVER_XORG_SERVER_AIGLX
bool "Enable AIGLX Extension"
- depends on BR2_PACKAGE_XSERVER_XORG_SERVER
help
Enable/Use AIGLX extension.
+
+comment "Optional Servers"
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB
+ bool "Xvfb server"
+ help
+ Virtual frame buffer X server.
+
+endif
@@ -57,10 +57,11 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
host-pkg-config
XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
- --disable-xnest --disable-xephyr --disable-xvfb \
+ --disable-xnest --disable-xephyr \
--with-builder-addr=buildroot@uclibc.org \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/pixman-1" \
- --with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var
+ --with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var \
+ --$(if $(BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB),en,dis)able-xvfb
ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
XSERVER_XORG_SERVER_CONF_OPT += --enable-xorg
Signed-off-by: Ismael Luceno <ismael.luceno@gmail.com> --- package/x11r7/xserver_xorg-server/Config.in | 13 +++++++++++-- .../xserver_xorg-server/xserver_xorg-server.mk | 5 +++-- 2 files changed, 14 insertions(+), 4 deletions(-)