diff mbox

[v2] Add fmtools package.

Message ID 1333282723-7276-1-git-send-email-marek.belisko@open-nandra.com
State Accepted
Headers show

Commit Message

Marek Belisko April 1, 2012, 12:18 p.m. UTC
Change from v1:
- use $(TARGET_CONFIGURE_OPTS) instead of setting CC and LD individually
  (thanks Baruch)

Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
---
 package/Config.in          |    1 +
 package/fmtools/Config.in  |    9 +++++++++
 package/fmtools/fmtools.mk |   19 +++++++++++++++++++
 3 files changed, 29 insertions(+), 0 deletions(-)
 create mode 100644 package/fmtools/Config.in
 create mode 100644 package/fmtools/fmtools.mk

Comments

Peter Korsgaard April 8, 2012, 7:44 a.m. UTC | #1
>>>>> "Marek" == Marek Belisko <marek.belisko@open-nandra.com> writes:

Hi,

 Marek> Change from v1:
 Marek> - use $(TARGET_CONFIGURE_OPTS) instead of setting CC and LD individually
 Marek>   (thanks Baruch)

This info should go after the '---' line, as otherwise 'git am' will add
it to the commit message.


 Marek> diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
 Marek> new file mode 100644
 Marek> index 0000000..41c883c
 Marek> --- /dev/null
 Marek> +++ b/package/fmtools/Config.in
 Marek> @@ -0,0 +1,9 @@
 Marek> +config BR2_PACKAGE_FMTOOLS
 Marek> +	bool "fmtools"
 Marek> +	help
 Marek> +	  fmtools is a pair of simple command-line utilities for
 Marek> +	  “video4linux” radio tuner cards under Linux. It includes

Menuconfig shows rubbish for these unicode quotes, so I replaced them
with normal ascii ones.


 Marek> +++ b/package/fmtools/fmtools.mk
 Marek> @@ -0,0 +1,19 @@
 Marek> +#############################################################
 Marek> +#
 Marek> +# fmtools
 Marek> +#
 Marek> +#############################################################
 Marek> +
 Marek> +FMTOOLS_VERSION = 1.0.2
 Marek> +FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
 Marek> +
 Marek> +define FMTOOLS_BUILD_CMDS
 Marek> +	$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 Marek> +endef
 Marek> +
 Marek> +define FMTOOLS_INSTALL_TARGET_CMDS
 Marek> +	$(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin
 Marek> +	$(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin

With install -D you have to provide the destination filename as well, so
I adjusted these two lines.

Committed with these fixes, thanks.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 68d28fa..94faf44 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -175,6 +175,7 @@  source "package/e2fsprogs/Config.in"
 source "package/eeprog/Config.in"
 source "package/fconfig/Config.in"
 source "package/fis/Config.in"
+source "package/fmtools/Config.in"
 source "package/gadgetfs-test/Config.in"
 source "package/gdisk/Config.in"
 source "package/genext2fs/Config.in"
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644
index 0000000..41c883c
--- /dev/null
+++ b/package/fmtools/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_FMTOOLS
+	bool "fmtools"
+	help
+	  fmtools is a pair of simple command-line utilities for
+	  “video4linux” radio tuner cards under Linux. It includes
+	  fm for power control, tuning, and volume and fmscan for
+	  scanning for stations.
+
+	  http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644
index 0000000..32facd6
--- /dev/null
+++ b/package/fmtools/fmtools.mk
@@ -0,0 +1,19 @@ 
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+	$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+	$(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin
+	$(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin
+endef
+
+$(eval $(call GENTARGETS))