@@ -382,6 +382,7 @@ source "package/libelf/Config.in"
source "package/libevent/Config.in"
source "package/libev/Config.in"
source "package/libffi/Config.in"
+source "package/libgsl/Config.in"
source "package/libglib2/Config.in"
source "package/libical/Config.in"
source "package/libnspr/Config.in"
new file mode 100644
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBGSL
+ bool "libgsl"
+ help
+ The GNU Scientific Library (GSL) is a numerical library for C and C++ programmers.
+ The library provides a wide range of mathematical routines such as random number generators,
+ special functions and least-squares fitting.
+ There are over 1000 functions in total with an extensive test suite.
+ http://www.gnu.org/software/gsl
new file mode 100644
@@ -0,0 +1,11 @@
+#############################################################
+#
+# gnu gsl
+#
+#############################################################
+LIBGSL_VERSION = 1.15
+LIBGSL_SOURCE = gsl-$(LIBGSL_VERSION).tar.gz
+LIBGSL_SITE = $(BR2_GNU_MIRROR)/gsl
+LIBGSL_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS))
Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> --- package/Config.in | 1 + package/libgsl/Config.in | 8 ++++++++ package/libgsl/gsl.mk | 11 +++++++++++ 3 files changed, 20 insertions(+) create mode 100644 package/libgsl/Config.in create mode 100644 package/libgsl/gsl.mk