@@ -1,10 +1,10 @@
Infrastructure for autotools-based packages
--------------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[[autotargets-tutorial]]
+AUTOTARGETS+ tutorial
-~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^
First, let's see how to write a +.mk+ file for an autotools-based
package, with an example :
@@ -64,7 +64,7 @@ package to be built.
[[autotargets-reference]]
+AUTOTARGETS+ reference
-~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^
The main macro of the autotools package infrastructure is
+AUTOTARGETS+. It has the same number of arguments and the
@@ -1,10 +1,10 @@
Infrastructure for CMake-based packages
----------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[[cmaketargets-tutorial]]
+CMAKETARGETS+ tutorial
-~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^
First, let's see how to write a +.mk+ file for a CMake-based package,
with an example :
@@ -63,7 +63,7 @@ package to be built.
[[cmaketargets-reference]]
+CMAKETARGETS+ reference
-~~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^^
The main macro of the CMake package infrastructure is
+CMAKETARGETS+. It has the same number of arguments and the same
@@ -1,5 +1,5 @@
Conclusion
-----------
+~~~~~~~~~~
As you can see, adding a software package to Buildroot is simply a
matter of writing a Makefile using an existing example and modifying it
@@ -1,5 +1,5 @@
Package directory
------------------
+~~~~~~~~~~~~~~~~~
First of all, create a directory under the +package+ directory for
your software, for example +libfoo+.
@@ -10,7 +10,7 @@ one of these categories, then create your package directory in these.
+Config.in+ file
-~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^
Then, create a file named +Config.in+. This file will contain the
option descriptions related to our +libfoo+ software that will be used
@@ -146,7 +146,7 @@ so, the dependency also needs to be expressed in the +.mk+ file of the
package.
The +.mk+ file
-~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^
Finally, here's the hardest part. Create a file named +libfoo.mk+. It
describes how the package should be downloaded, configured, built,
@@ -1,5 +1,5 @@
Infrastructure for packages with specific build systems
--------------------------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
By 'packages with specific build systems' we mean all the packages
whose build system is not one of the standard ones, such as
@@ -9,7 +9,7 @@ system is based on hand-written Makefiles or shell scripts.
[[gentargets-tutorial]]
+GENTARGETS+ Tutorial
-~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^
------------------------------
01: #############################################################
@@ -90,7 +90,7 @@ Makefile code necessary to make your package working.
[[gentargets-reference]]
+GENTARGETS+ Reference
-~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^
The +GENTARGETS+ macro takes one optional argument. This argument can
be used to tell if the package is a target package (cross-compiled for
@@ -1,5 +1,5 @@
Gettext integration and interaction with packages
--------------------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Many packages that support internationalization use the gettext
library. Dependencies for this library are fairly complicated and
@@ -1,7 +1,5 @@
-[[handwritten-tutorial]]
-
Manual Makefile
----------------
+~~~~~~~~~~~~~~~
*NOTE: new manual makefiles should not be created, and existing manual
makefiles should be converted either to the generic, autotools or
@@ -1,5 +1,6 @@
+[[adding-packages]]
Adding new packages to Buildroot
-================================
+--------------------------------
This section covers how new packages (userspace libraries or
applications) can be integrated into Buildroot. It also shows how
new file mode 100644
@@ -0,0 +1,10 @@
+Advanced usage
+--------------
+
+include::using-buildroot-toolchain.txt[]
+
+include::external-toolchain.txt[]
+
+include::ccache-support.txt[]
+
+include::download-location.txt[]
@@ -1,5 +1,6 @@
+[[board-support]]
Creating your own board support
-===============================
+-------------------------------
Creating your own board support in Buildroot allows users of a
particular hardware platform to easily build a system that is known to
@@ -1,5 +1,6 @@
+[[ccache]]
Using +ccache+ in Buildroot
-===========================
+~~~~~~~~~~~~~~~~~~~~~~~~~~~
http://ccache.samba.org[ccache] is a compiler cache. It stores the
object files resulting from each compilation process, and is able to
new file mode 100644
@@ -0,0 +1,4 @@
+Daily use
+---------
+
+include::rebuilding-packages.txt[]
new file mode 100644
@@ -0,0 +1,2 @@
+Contibuting to Buildroot
+========================
@@ -1,6 +1,6 @@
-Customizing the Busybox configuration
--------------------------------------
[[busybox-custom]]
+Customizing the Busybox configuration
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
http://www.busybox.net/[Busybox] is very configurable, and you may
want to customize it. You can follow these simple steps to do so. This
@@ -20,5 +20,5 @@ Otherwise, you can simply change the
options you want to change, without using the configuration tool.
If you want to use an existing config file for busybox, then see
-section xref:env-vars[].
+xref:env-vars[].
@@ -1,5 +1,6 @@
+[[kernel-custom]]
Customizing the Linux kernel configuration
-------------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
The Linux kernel configuration can be customized just like
xref:busybox-custom[BusyBox] and xref:uclibc-custom[uClibc] using
@@ -1,5 +1,6 @@
+[[rootfs-custom]]
Customizing the generated target filesystem
--------------------------------------------
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
There are a few ways to customize the resulting target filesystem:
@@ -1,12 +1,12 @@
-Customizing the toolchain
--------------------------
[[toolchain-custom]]
+Customizing the toolchain
+~~~~~~~~~~~~~~~~~~~~~~~~~
There are three distinct types of toolchain backend supported in Buildroot,
available under the menu +Toolchain+, invoking +make menuconfig+.
Using the external toolchain backend
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
There is no way of tuning an external toolchain since Buildroot does not
generate it.
@@ -15,7 +15,7 @@ It also requires to set the Buildroot settings according to the toolchain ones
(see xref:external-toolchain[]).
Using the internal Buildroot toolchain backend
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The internal Buildroot toolchain backend *only* allows to generate
*http://www.uclibc.org/[uClibc]-based toolchains*.
@@ -32,7 +32,7 @@ This is directly available after selecting the +Buildroot toolchain+ type in
the menu +Toolchain+.
Using the Crosstool-NG backend
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The http://crosstool-ng.org[crosstool-NG] toolchain backend enables a rather
limited set of settings under the Buildroot +Toolchain+ menu (ie. when invoking
@@ -1,6 +1,6 @@
-Customizing the uClibc configuration
-------------------------------------
[[uclibc-custom]]
+Customizing the uClibc configuration
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Just like xref:busybox-custom[BusyBox], http://www.uclibc.org/[uClibc]
offers a lot of configuration options. They allow you to select
@@ -1,5 +1,5 @@
Customization
-=============
+-------------
include::customize-rootfs.txt[]
new file mode 100644
@@ -0,0 +1,8 @@
+Developer Guidelines
+====================
+
+include::writing-rules.txt[]
+
+include::adding-packages.txt[]
+
+include::board-support.txt[]
@@ -1,5 +1,5 @@
Location of downloaded packages
-===============================
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
It might be useful to know that the various tarballs that are
downloaded by the Makefiles are all stored in the +DL_DIR+ which by
new file mode 100644
@@ -0,0 +1,2 @@
+Embedded system basics & Reasons to use Buildroot
+-------------------------------------------------
@@ -1,6 +1,6 @@
-Using an external toolchain
-===========================
[[external-toolchain]]
+Using an external toolchain
+~~~~~~~~~~~~~~~~~~~~~~~~~~~
Using an already existing toolchain is useful for different
reasons:
new file mode 100644
@@ -0,0 +1,2 @@
+Getting involved
+================
@@ -1,5 +1,6 @@
+[[getting-buildroot]]
Getting Buildroot
-=================
+-----------------
Buildroot releases are made approximately every 3 months. Direct Git
access and daily snapshots are also available, if you want more
new file mode 100644
@@ -0,0 +1,8 @@
+Going further in Buildroot's innards
+====================================
+
+include::embedded-basics.txt[]
+
+include::how-buildroot-works.txt[]
+
+include::advanced.txt[]
@@ -1,5 +1,5 @@
How Buildroot works
-===================
+-------------------
As mentioned above, Buildroot is basically a set of Makefiles that
download, configure, and compile software with the correct options. It
new file mode 100644
@@ -0,0 +1,4 @@
+Legal notice
+============
+
+TODO
new file mode 100644
@@ -0,0 +1,2 @@
+'make' tips
+-----------
@@ -11,24 +11,25 @@ image::logo.png[]
include::introduction.txt[]
-include::getting.txt[]
+include::starting-up.txt[]
-include::using.txt[]
-include::customize.txt[]
-include::rebuilding-packages.txt[]
+include::working-with.txt[]
-include::how-buildroot-works.txt[]
+include::troubleshooting.txt[]
-include::using-buildroot-toolchain.txt[]
-include::external-toolchain.txt[]
-include::ccache-support.txt[]
+include::going-further.txt[]
-include::download-location.txt[]
+include::developer-guide.txt[]
+
+include::get-involved.txt[]
+
+include::contribute.txt[]
+
+include::legal-notice.txt[]
-include::adding-packages.txt[]
include::appendix.txt[]
new file mode 100644
@@ -0,0 +1,2 @@
+System requirements
+-------------------
@@ -1,5 +1,5 @@
Understanding how to rebuild packages
-=====================================
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
One of the most common questions asked by Buildroot users is how to
rebuild a given package or how to remove a package without rebuilding
new file mode 100644
@@ -0,0 +1,9 @@
+Starting up
+===========
+
+include::prerequisite.txt[]
+
+include::getting.txt[]
+
+include::using.txt[]
+
new file mode 100644
@@ -0,0 +1,2 @@
+Troubleshooting
+===============
@@ -1,5 +1,5 @@
Using the generated toolchain outside Buildroot
-===============================================
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
You may want to compile, for your target, your own programs or other
software that are not packaged in Buildroot. In order to do this you
new file mode 100644
@@ -0,0 +1,12 @@
+Working with Buildroot
+======================
+[[working-with-br]]
+
+include::make-tips.txt[]
+
+include::customize.txt[]
+
+include::common-usage.txt[]
+
+Tweaking Buildroot
+------------------
new file mode 100644
@@ -0,0 +1,11 @@
+Writing rules
+-------------
+
++Config.in+ file
+~~~~~~~~~~~~~~~~
+
+The +.mk+ file
+~~~~~~~~~~~~~~
+
+The documentation
+~~~~~~~~~~~~~~~~~
The new skeleton of the manual as it has been thought: 1. About Buildroot: Presentation of Buildroot 2. Starting up: Everything to quickly and easily start working with Buildroot 3. Working with Buildroot Basics to make your work fitting your needs 4. Troubleshooting 5. Going further in Buildroot's innards Explaination of how buildroot is organised, how it works, etc 6. Developer Guidelines 7. Getting involved 8. Contibuting to Buildroot 9. Legal notice 10. Appendix It is easy to distinguish two parts in this plan: - Sections 1 to 4 mainly address people starting with Buildroot - Sections 5 to 10 are more focused on how to develop Buildroot itself Most of the existing sections have just been moved in the hierarchy, few were split and dispatch in, what i think was the relevant section, and numerous others have been created. Signed-off-by: Samuel MARTIN <s.martin49@gmail.com> --- docs/manual/adding-packages-autotargets.txt | 6 +++--- docs/manual/adding-packages-cmaketargets.txt | 6 +++--- docs/manual/adding-packages-conclusion.txt | 2 +- docs/manual/adding-packages-directory.txt | 6 +++--- docs/manual/adding-packages-gentargets.txt | 6 +++--- docs/manual/adding-packages-gettext.txt | 2 +- docs/manual/adding-packages-handwritten.txt | 4 +--- docs/manual/adding-packages.txt | 3 ++- docs/manual/advanced.txt | 10 ++++++++++ docs/manual/board-support.txt | 3 ++- docs/manual/ccache-support.txt | 3 ++- docs/manual/common-usage.txt | 4 ++++ docs/manual/contribute.txt | 2 ++ docs/manual/customize-busybox-config.txt | 6 +++--- docs/manual/customize-kernel-config.txt | 3 ++- docs/manual/customize-rootfs.txt | 3 ++- docs/manual/customize-toolchain.txt | 10 +++++----- docs/manual/customize-uclibc-config.txt | 4 ++-- docs/manual/customize.txt | 2 +- docs/manual/developer-guide.txt | 8 ++++++++ docs/manual/download-location.txt | 2 +- docs/manual/embedded-basics.txt | 2 ++ docs/manual/external-toolchain.txt | 4 ++-- docs/manual/get-involved.txt | 2 ++ docs/manual/getting.txt | 3 ++- docs/manual/going-further.txt | 8 ++++++++ docs/manual/how-buildroot-works.txt | 2 +- docs/manual/legal-notice.txt | 4 ++++ docs/manual/make-tips.txt | 2 ++ docs/manual/manual.txt | 21 +++++++++++---------- docs/manual/prerequisite.txt | 2 ++ docs/manual/rebuilding-packages.txt | 2 +- docs/manual/starting-up.txt | 9 +++++++++ docs/manual/troubleshooting.txt | 2 ++ docs/manual/using-buildroot-toolchain.txt | 2 +- docs/manual/working-with.txt | 12 ++++++++++++ docs/manual/writing-rules.txt | 11 +++++++++++ 37 files changed, 133 insertions(+), 50 deletions(-) create mode 100644 docs/manual/advanced.txt create mode 100644 docs/manual/common-usage.txt create mode 100644 docs/manual/contribute.txt create mode 100644 docs/manual/developer-guide.txt create mode 100644 docs/manual/embedded-basics.txt create mode 100644 docs/manual/get-involved.txt create mode 100644 docs/manual/going-further.txt create mode 100644 docs/manual/legal-notice.txt create mode 100644 docs/manual/make-tips.txt create mode 100644 docs/manual/prerequisite.txt create mode 100644 docs/manual/starting-up.txt create mode 100644 docs/manual/troubleshooting.txt create mode 100644 docs/manual/working-with.txt create mode 100644 docs/manual/writing-rules.txt