diff mbox

[rs6000] Rename GCC version in warning messages

Message ID 201409181650.s8IGoe3I028797@d06av02.portsmouth.uk.ibm.com
State New
Headers show

Commit Message

Ulrich Weigand Sept. 18, 2014, 4:50 p.m. UTC
Hello,

the ABI warning messages I introduced in recent patches refer to a GCC
version "4.10".  As GCC has since adopted a new version naming scheme,
this patch updates those messages to refer to "GCC 5" instead.

Tested on powerpc64le-linux.

OK for mainline?

Bye,
Ulrich


ChangeLog:

	* config/rs6000/rs6000.c (rs6000_special_adjust_field_align_p):
	Update GCC version name to GCC 5.
	(rs6000_function_arg_boundary): Likewise.
	(rs6000_function_arg): Likewise.

Comments

David Edelsohn Sept. 19, 2014, 3:37 p.m. UTC | #1
On Thu, Sep 18, 2014 at 12:50 PM, Ulrich Weigand <uweigand@de.ibm.com> wrote:
> Hello,
>
> the ABI warning messages I introduced in recent patches refer to a GCC
> version "4.10".  As GCC has since adopted a new version naming scheme,
> this patch updates those messages to refer to "GCC 5" instead.
>
> Tested on powerpc64le-linux.
>
> OK for mainline?
>
> Bye,
> Ulrich
>
>
> ChangeLog:
>
>         * config/rs6000/rs6000.c (rs6000_special_adjust_field_align_p):
>         Update GCC version name to GCC 5.
>         (rs6000_function_arg_boundary): Likewise.
>         (rs6000_function_arg): Likewise.

Okay.

Thanks, David
diff mbox

Patch

Index: gcc/config/rs6000/rs6000.c
===================================================================
--- gcc/config/rs6000/rs6000.c	(revision 215355)
+++ gcc/config/rs6000/rs6000.c	(working copy)
@@ -5939,7 +5939,7 @@ 
 	      warned = true;
 	      inform (input_location,
 		      "the layout of aggregates containing vectors with"
-		      " %d-byte alignment has changed in GCC 4.10",
+		      " %d-byte alignment has changed in GCC 5",
 		      computed / BITS_PER_UNIT);
 	    }
 	}
@@ -9307,7 +9307,7 @@ 
 	      warned = true;
 	      inform (input_location,
 		      "the ABI of passing aggregates with %d-byte alignment"
-		      " has changed in GCC 4.10",
+		      " has changed in GCC 5",
 		      (int) TYPE_ALIGN (type) / BITS_PER_UNIT);
 	    }
 	}
@@ -10428,7 +10428,7 @@ 
 		  warned = true;
 		  inform (input_location,
 			  "the ABI of passing homogeneous float aggregates"
-			  " has changed in GCC 4.10");
+			  " has changed in GCC 5");
 		}
 	    }