diff mbox

[U-Boot] mx53loco: Remove unneeded gpio_set_value()

Message ID 1336423377-15718-1-git-send-email-festevam@gmail.com
State Accepted
Commit 6ecaee8201ddf7dd574e9331ad4249ec867253b5
Headers show

Commit Message

Fabio Estevam May 7, 2012, 8:42 p.m. UTC
From: Fabio Estevam <fabio.estevam@freescale.com>

There is no need to set the VBUS power enable to 0 first and then to 1.

Set it to 1 in the gpio_direction_output() function.

While at it, use the standard naming convention for the GPIO comment.

Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
---
 board/freescale/mx53loco/mx53loco.c |    5 ++---
 1 files changed, 2 insertions(+), 3 deletions(-)

Comments

Stefano Babic May 9, 2012, 9:20 a.m. UTC | #1
On 07/05/2012 22:42, Fabio Estevam wrote:
> From: Fabio Estevam <fabio.estevam@freescale.com>
> 
> There is no need to set the VBUS power enable to 0 first and then to 1.
> 
> Set it to 1 in the gpio_direction_output() function.
> 
> While at it, use the standard naming convention for the GPIO comment.
> 
> Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
> ---

Applied to u-boot-imx, thanks.

Best regards,
Stefano Babic
diff mbox

Patch

diff --git a/board/freescale/mx53loco/mx53loco.c b/board/freescale/mx53loco/mx53loco.c
index 2f2c00c..c9d0c19 100644
--- a/board/freescale/mx53loco/mx53loco.c
+++ b/board/freescale/mx53loco/mx53loco.c
@@ -92,10 +92,9 @@  static void setup_iomux_uart(void)
 #ifdef CONFIG_USB_EHCI_MX5
 int board_ehci_hcd_init(int port)
 {
-	/* request VBUS power enable pin, GPIO[8}, gpio7 */
+	/* request VBUS power enable pin, GPIO7_8 */
 	mxc_request_iomux(MX53_PIN_ATA_DA_2, IOMUX_CONFIG_ALT1);
-	gpio_direction_output(IOMUX_TO_GPIO(MX53_PIN_ATA_DA_2), 0);
-	gpio_set_value(IOMUX_TO_GPIO(MX53_PIN_ATA_DA_2), 1);
+	gpio_direction_output(IOMUX_TO_GPIO(MX53_PIN_ATA_DA_2), 1);
 	return 0;
 }
 #endif