mbox series

[GIT,PULL] Please pull u-boot-dfu-next-20240820

Message ID 87r0ajuxbz.fsf@baylibre.com
State Accepted
Delegated to: Tom Rini
Headers show
Series [GIT,PULL] Please pull u-boot-dfu-next-20240820 | expand

Pull-request

https://source.denx.de/u-boot/custodians/u-boot-dfu.git tags/u-boot-dfu-next-20240820

Message

Mattijs Korpershoek Aug. 20, 2024, 1:40 p.m. UTC
Hi Tom,

Please find some developments for next:

- Migrate Atmel usb gadget to DM_USB_GADGET
- More small cleanups/improvements on the atmel UDC driver
- Change udc uclass name from "usb" -> "usb_gadget"

CI job:
- https://source.denx.de/u-boot/custodians/u-boot-dfu/-/pipelines/22060

Thanks,
Mattijs

The following changes since commit 6f4c31c2b658358628b5b0fa801f55c7477c7585:

  Prepare v2024.10-rc2 (2024-08-05 18:13:42 -0600)

are available in the Git repository at:

  https://source.denx.de/u-boot/custodians/u-boot-dfu.git tags/u-boot-dfu-next-20240820

for you to fetch changes up to 73f5b54a589cb6ff97aaca55e7c97d68b43997ee:

  usb: gadget: udc: Fix duplicate uclass name (2024-08-20 09:36:36 +0200)

----------------------------------------------------------------
u-boot-dfu-next-20240820

- Migrate Atmel usb gadget to DM_USB_GADGET
- More small cleanups/improvements on the atmel UDC driver
- Change udc uclass name from "usb" -> "usb_gadget"

----------------------------------------------------------------
Zixun LI (8):
      usb: gadget: atmel: Sort includes
      usb: gadget: atmel: Replace printf() and pr_err() by log_err()
      usb: gadget: atmel: Fix typo in usb gadget driver register and unregister
      usb: gadget: atmel: Move usba_udc_pdata() with other static functions
      usb: gadget: atmel: Rename atmel_usba_start()/_stop() to usba_udc_enable()/_disable()
      usb: gadget: atmel: Add attach/detach support
      usb: gadget: atmel: Add DM_USB_GADGET support
      usb: gadget: udc: Fix duplicate uclass name

 drivers/usb/gadget/atmel_usba_udc.c | 256 +++++++++++++++++++++++++++++-------
 drivers/usb/gadget/atmel_usba_udc.h |   3 +
 drivers/usb/gadget/udc/udc-uclass.c |   2 +-
 include/linux/usb/atmel_usba_udc.h  |   2 +
 4 files changed, 215 insertions(+), 48 deletions(-)

Comments

Tom Rini Aug. 21, 2024, 12:42 a.m. UTC | #1
On Tue, Aug 20, 2024 at 03:40:16PM +0200, Mattijs Korpershoek wrote:

> Hi Tom,
> 
> Please find some developments for next:
> 
> - Migrate Atmel usb gadget to DM_USB_GADGET
> - More small cleanups/improvements on the atmel UDC driver
> - Change udc uclass name from "usb" -> "usb_gadget"
> 
> CI job:
> - https://source.denx.de/u-boot/custodians/u-boot-dfu/-/pipelines/22060
> 
> Thanks,
> Mattijs
> 
> The following changes since commit 6f4c31c2b658358628b5b0fa801f55c7477c7585:
> 
>   Prepare v2024.10-rc2 (2024-08-05 18:13:42 -0600)
> 
> are available in the Git repository at:
> 
>   https://source.denx.de/u-boot/custodians/u-boot-dfu.git tags/u-boot-dfu-next-20240820
> 
> for you to fetch changes up to 73f5b54a589cb6ff97aaca55e7c97d68b43997ee:
> 
>   usb: gadget: udc: Fix duplicate uclass name (2024-08-20 09:36:36 +0200)
> 

Applied to u-boot/next, thanks!