mbox series

[v3,0/2] hwmon: (pmbus) Add support for Infineon XDP710

Message ID 20240429033833.895122-1-peteryin.openbmc@gmail.com
Headers show
Series hwmon: (pmbus) Add support for Infineon XDP710 | expand

Message

Peter Yin April 29, 2024, 3:38 a.m. UTC
Add support for Infineon XDP710. This is a Hot-Swap Controller.

Change log:

v2 -> v3
    - Fixed Ack quotes
    - rename "microOhmRsense" to "micro_ohm_rsense" 

v1 -> v2
    - Merged patch 3 into patch 1.
    - Modified comments.
    - Fixed the microOhmRsense array.
    - Improved operational accuracy.

v1
    - Add support for xdp710 hot-swap device from Infineon vendor
---

Peter Yin (2):
  hwmon: (pmbus) Add support for Infineon XDP710
  dt-bindings: hwmon: Add infineon xdp710 driver bindings

 .../devicetree/bindings/trivial-devices.yaml  |   2 +
 Documentation/hwmon/index.rst                 |   1 +
 Documentation/hwmon/xdp710.rst                |  83 +++++++++++
 drivers/hwmon/pmbus/Kconfig                   |   9 ++
 drivers/hwmon/pmbus/Makefile                  |   1 +
 drivers/hwmon/pmbus/xdp710.c                  | 132 ++++++++++++++++++
 6 files changed, 228 insertions(+)
 create mode 100644 Documentation/hwmon/xdp710.rst
 create mode 100644 drivers/hwmon/pmbus/xdp710.c

Comments

Krzysztof Kozlowski April 29, 2024, 4:59 a.m. UTC | #1
On 29/04/2024 05:38, Peter Yin wrote:
> Add support for Infineon XDP710. This is a Hot-Swap Controller.
> 
> Change log:
> 
> v2 -> v3
>     - Fixed Ack quotes
>     - rename "microOhmRsense" to "micro_ohm_rsense" 

You got the message it was applied, didn't you?

Best regards,
Krzysztof
Guenter Roeck April 29, 2024, 5 a.m. UTC | #2
On 4/28/24 20:38, Peter Yin wrote:
> Add support for Infineon XDP710. This is a Hot-Swap Controller.
> 
> Change log:
> 
> v2 -> v3
>      - Fixed Ack quotes
>      - rename "microOhmRsense" to "micro_ohm_rsense"
> 
> v1 -> v2
>      - Merged patch 3 into patch 1.
>      - Modified comments.
>      - Fixed the microOhmRsense array.
>      - Improved operational accuracy.
> 
> v1
>      - Add support for xdp710 hot-swap device from Infineon vendor
> ---
> 
> Peter Yin (2):
>    hwmon: (pmbus) Add support for Infineon XDP710
>    dt-bindings: hwmon: Add infineon xdp710 driver bindings
> 
>   .../devicetree/bindings/trivial-devices.yaml  |   2 +
>   Documentation/hwmon/index.rst                 |   1 +
>   Documentation/hwmon/xdp710.rst                |  83 +++++++++++
>   drivers/hwmon/pmbus/Kconfig                   |   9 ++
>   drivers/hwmon/pmbus/Makefile                  |   1 +
>   drivers/hwmon/pmbus/xdp710.c                  | 132 ++++++++++++++++++
>   6 files changed, 228 insertions(+)
>   create mode 100644 Documentation/hwmon/xdp710.rst
>   create mode 100644 drivers/hwmon/pmbus/xdp710.c
> 

What is the point of resending this ? I said I applied the series.

Guenter
Peter Yin April 29, 2024, 5:18 a.m. UTC | #3
Sorry, I thought it was going to be applied after I fixed it.

On Mon, Apr 29, 2024 at 1:00 PM Guenter Roeck <linux@roeck-us.net> wrote:
>
> On 4/28/24 20:38, Peter Yin wrote:
> > Add support for Infineon XDP710. This is a Hot-Swap Controller.
> >
> > Change log:
> >
> > v2 -> v3
> >      - Fixed Ack quotes
> >      - rename "microOhmRsense" to "micro_ohm_rsense"
> >
> > v1 -> v2
> >      - Merged patch 3 into patch 1.
> >      - Modified comments.
> >      - Fixed the microOhmRsense array.
> >      - Improved operational accuracy.
> >
> > v1
> >      - Add support for xdp710 hot-swap device from Infineon vendor
> > ---
> >
> > Peter Yin (2):
> >    hwmon: (pmbus) Add support for Infineon XDP710
> >    dt-bindings: hwmon: Add infineon xdp710 driver bindings
> >
> >   .../devicetree/bindings/trivial-devices.yaml  |   2 +
> >   Documentation/hwmon/index.rst                 |   1 +
> >   Documentation/hwmon/xdp710.rst                |  83 +++++++++++
> >   drivers/hwmon/pmbus/Kconfig                   |   9 ++
> >   drivers/hwmon/pmbus/Makefile                  |   1 +
> >   drivers/hwmon/pmbus/xdp710.c                  | 132 ++++++++++++++++++
> >   6 files changed, 228 insertions(+)
> >   create mode 100644 Documentation/hwmon/xdp710.rst
> >   create mode 100644 drivers/hwmon/pmbus/xdp710.c
> >
>
> What is the point of resending this ? I said I applied the series.
>
> Guenter
>