Message ID | 20231205103559.9605-2-fancer.lancer@gmail.com |
---|---|
State | New |
Headers | show |
Series | net: pcs: xpcs: Add memory-based management iface support | expand |
On Tue, Dec 05, 2023 at 01:35:22PM +0300, Serge Semin wrote: > There are currently two methods (xpcs_find_compat() and > xpcs_get_interfaces()) defined in the driver which loop over the available > interfaces. All of them rely on the xpcs_compat.num_interfaces field value > to get the number of interfaces. That field is initialized with the > ARRAY_SIZE(xpcs_*_interfaces) macro function call. Thus the interface > arrays are supposed to be filled with actual interface IDs and there is no > need in the dummy terminating ID placed at the end of the arrays. Let's > drop the redundant PHY_INTERFACE_MODE_MAX entry from the > xpcs_2500basex_interfaces list and the redundant > PHY_INTERFACE_MODE_MAX-based conditional statement from the > xpcs_get_interfaces() method then. It would help the readability of the commit message if you would split it into multiple paragraphs. > > Signed-off-by: Serge Semin <fancer.lancer@gmail.com> > --- Reviewed-by: Vladimir Oltean <vladimir.oltean@nxp.com>
On Tue, Dec 05, 2023 at 01:24:29PM +0200, Vladimir Oltean wrote: > On Tue, Dec 05, 2023 at 01:35:22PM +0300, Serge Semin wrote: > > There are currently two methods (xpcs_find_compat() and > > xpcs_get_interfaces()) defined in the driver which loop over the available > > interfaces. All of them rely on the xpcs_compat.num_interfaces field value > > to get the number of interfaces. That field is initialized with the > > ARRAY_SIZE(xpcs_*_interfaces) macro function call. Thus the interface > > arrays are supposed to be filled with actual interface IDs and there is no > > need in the dummy terminating ID placed at the end of the arrays. Let's > > drop the redundant PHY_INTERFACE_MODE_MAX entry from the > > xpcs_2500basex_interfaces list and the redundant > > PHY_INTERFACE_MODE_MAX-based conditional statement from the > > xpcs_get_interfaces() method then. > > It would help the readability of the commit message if you would split > it into multiple paragraphs. Yeah, creating sometimes overcomplicated log messages is my eternal problem.) Ok. I'll split it up. > > > > > Signed-off-by: Serge Semin <fancer.lancer@gmail.com> > > --- > > Reviewed-by: Vladimir Oltean <vladimir.oltean@nxp.com> Thanks. -Serge(y)
diff --git a/drivers/net/pcs/pcs-xpcs.c b/drivers/net/pcs/pcs-xpcs.c index 31f0beba638a..dc7c374da495 100644 --- a/drivers/net/pcs/pcs-xpcs.c +++ b/drivers/net/pcs/pcs-xpcs.c @@ -130,7 +130,6 @@ static const phy_interface_t xpcs_1000basex_interfaces[] = { static const phy_interface_t xpcs_2500basex_interfaces[] = { PHY_INTERFACE_MODE_2500BASEX, - PHY_INTERFACE_MODE_MAX, }; enum { @@ -636,8 +635,7 @@ void xpcs_get_interfaces(struct dw_xpcs *xpcs, unsigned long *interfaces) const struct xpcs_compat *compat = &xpcs->id->compat[i]; for (j = 0; j < compat->num_interfaces; j++) - if (compat->interface[j] < PHY_INTERFACE_MODE_MAX) - __set_bit(compat->interface[j], interfaces); + __set_bit(compat->interface[j], interfaces); } } EXPORT_SYMBOL_GPL(xpcs_get_interfaces);
There are currently two methods (xpcs_find_compat() and xpcs_get_interfaces()) defined in the driver which loop over the available interfaces. All of them rely on the xpcs_compat.num_interfaces field value to get the number of interfaces. That field is initialized with the ARRAY_SIZE(xpcs_*_interfaces) macro function call. Thus the interface arrays are supposed to be filled with actual interface IDs and there is no need in the dummy terminating ID placed at the end of the arrays. Let's drop the redundant PHY_INTERFACE_MODE_MAX entry from the xpcs_2500basex_interfaces list and the redundant PHY_INTERFACE_MODE_MAX-based conditional statement from the xpcs_get_interfaces() method then. Signed-off-by: Serge Semin <fancer.lancer@gmail.com> --- drivers/net/pcs/pcs-xpcs.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)