mbox series

[net-next,0/4] net: dsa: b53: ARL improvements

Message ID 20200430184911.29660-1-f.fainelli@gmail.com
Headers show
Series net: dsa: b53: ARL improvements | expand

Message

Florian Fainelli April 30, 2020, 6:49 p.m. UTC
Hi all,

This patch series improves the b53 driver ARL search code by
renaming the ARL entries to be reflective of what they are: bins, and
then introduce the number of buckets so we can properly bound check ARL
searches.

The final patch removes an unused argument.

Florian Fainelli (4):
  net: dsa: b53: Rename num_arl_entries to num_arl_bins
  net: dsa: b53: Provide number of ARL buckets
  net: dsa: b53: Bound check ARL searches
  net: dsa: b53: Remove is_static argument to b53_read_op()

 drivers/net/dsa/b53/b53_common.c | 81 ++++++++++++++++++++------------
 drivers/net/dsa/b53/b53_priv.h   |  8 +++-
 2 files changed, 58 insertions(+), 31 deletions(-)

Comments

David Miller May 1, 2020, 12:43 a.m. UTC | #1
From: Florian Fainelli <f.fainelli@gmail.com>
Date: Thu, 30 Apr 2020 11:49:07 -0700

> This patch series improves the b53 driver ARL search code by
> renaming the ARL entries to be reflective of what they are: bins, and
> then introduce the number of buckets so we can properly bound check ARL
> searches.
> 
> The final patch removes an unused argument.

Series applied, thanks.