diff mbox series

errorlog: Rename PHB3 to just PHB

Message ID 20180829071311.17497-1-ruscur@russell.cc
State Accepted
Headers show
Series errorlog: Rename PHB3 to just PHB | expand

Checks

Context Check Description
snowpatch_ozlabs/apply_patch success master/apply_patch Successfully applied
snowpatch_ozlabs/make_check success Test make_check on branch master

Commit Message

Russell Currey Aug. 29, 2018, 7:13 a.m. UTC
I don't see a reason why there would need to be a PHB3 *specific*
subsystem in the error logs, so rename it to PHB so that PHB4 and
later can use it too without continually redefining it.

This shouldn't change any existing assumptions because it's unused.

Signed-off-by: Russell Currey <ruscur@russell.cc>
---
 include/errorlog.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Oliver O'Halloran Aug. 30, 2018, 8 a.m. UTC | #1
On Wed, Aug 29, 2018 at 5:13 PM, Russell Currey <ruscur@russell.cc> wrote:
> I don't see a reason why there would need to be a PHB3 *specific*
> subsystem in the error logs, so rename it to PHB so that PHB4 and
> later can use it too without continually redefining it.

At a guess someone was planning on having separate ones for weird
p7ioc errors at some point, but no one uses those so who cares.

Reviewed-by: Oliver O'Halloran <oohall@gmail.com>

>
> This shouldn't change any existing assumptions because it's unused.
>
> Signed-off-by: Russell Currey <ruscur@russell.cc>
> ---
>  include/errorlog.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/errorlog.h b/include/errorlog.h
> index 285c185d..6da96649 100644
> --- a/include/errorlog.h
> +++ b/include/errorlog.h
> @@ -175,7 +175,7 @@ struct opal_err_info {
>  #define OPAL_UART                              0x5541  /* UA */
>  #define OPAL_OCC                               0x4F43  /* OC */
>  #define OPAL_OP_PANEL                          0x4F50  /* OP */
> -#define OPAL_PHB3                              0x5048  /* PH */
> +#define OPAL_PHB                               0x5048  /* PH */
>  #define OPAL_PSI                               0x5053  /* PS */
>  #define OPAL_VPD                               0x5650  /* VP */
>  #define OPAL_XSCOM                             0x5853  /* XS */
> @@ -222,7 +222,7 @@ struct opal_err_info {
>  #define OPAL_SRC_COMPONENT_UART                        0xb000
>  #define OPAL_SRC_COMPONENT_OCC                 0xc000
>  #define OPAL_SRC_COMPONENT_OP_PANEL            0xd000
> -#define OPAL_SRC_COMPONENT_PHB3                        0xe000
> +#define OPAL_SRC_COMPONENT_PHB                 0xe000
>  #define OPAL_SRC_COMPONENT_PSI                 0xf000
>
>  enum opal_reasoncode {
> --
> 2.17.1
>
> _______________________________________________
> Skiboot mailing list
> Skiboot@lists.ozlabs.org
> https://lists.ozlabs.org/listinfo/skiboot
Vasant Hegde Sept. 6, 2018, 5:32 a.m. UTC | #2
On 08/29/2018 12:43 PM, Russell Currey wrote:
> I don't see a reason why there would need to be a PHB3 *specific*
> subsystem in the error logs, so rename it to PHB so that PHB4 and
> later can use it too without continually redefining it.
> 
> This shouldn't change any existing assumptions because it's unused.
> 
> Signed-off-by: Russell Currey <ruscur@russell.cc>
> ---
>   include/errorlog.h | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/include/errorlog.h b/include/errorlog.h
> index 285c185d..6da96649 100644
> --- a/include/errorlog.h
> +++ b/include/errorlog.h
> @@ -175,7 +175,7 @@ struct opal_err_info {
>   #define OPAL_UART				0x5541  /* UA */
>   #define OPAL_OCC				0x4F43  /* OC */
>   #define OPAL_OP_PANEL				0x4F50  /* OP */
> -#define OPAL_PHB3				0x5048  /* PH */
> +#define OPAL_PHB				0x5048  /* PH */

IIRC original idea was to have separate component ID for different PHB's.
But we never added PEL format error logs to these components.

Reviewed-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>


-Vasant
Stewart Smith Sept. 18, 2018, 7:40 a.m. UTC | #3
Russell Currey <ruscur@russell.cc> writes:
> I don't see a reason why there would need to be a PHB3 *specific*
> subsystem in the error logs, so rename it to PHB so that PHB4 and
> later can use it too without continually redefining it.
>
> This shouldn't change any existing assumptions because it's unused.
>
> Signed-off-by: Russell Currey <ruscur@russell.cc>
> ---
>  include/errorlog.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Thanks, merged to master as of 19c8d728e86ef62c1cb366ae20bd6847b2221a8f
diff mbox series

Patch

diff --git a/include/errorlog.h b/include/errorlog.h
index 285c185d..6da96649 100644
--- a/include/errorlog.h
+++ b/include/errorlog.h
@@ -175,7 +175,7 @@  struct opal_err_info {
 #define OPAL_UART				0x5541  /* UA */
 #define OPAL_OCC				0x4F43  /* OC */
 #define OPAL_OP_PANEL				0x4F50  /* OP */
-#define OPAL_PHB3				0x5048  /* PH */
+#define OPAL_PHB				0x5048  /* PH */
 #define OPAL_PSI				0x5053  /* PS */
 #define OPAL_VPD				0x5650  /* VP */
 #define OPAL_XSCOM				0x5853  /* XS */
@@ -222,7 +222,7 @@  struct opal_err_info {
 #define OPAL_SRC_COMPONENT_UART			0xb000
 #define OPAL_SRC_COMPONENT_OCC			0xc000
 #define OPAL_SRC_COMPONENT_OP_PANEL		0xd000
-#define OPAL_SRC_COMPONENT_PHB3			0xe000
+#define OPAL_SRC_COMPONENT_PHB			0xe000
 #define OPAL_SRC_COMPONENT_PSI			0xf000
 
 enum opal_reasoncode {