mbox series

[U-Boot,v2,00/20] More support for Armada 37xx boards (for Turris Mox)

Message ID 20180424152131.20375-1-marek.behun@nic.cz
Headers show
Series More support for Armada 37xx boards (for Turris Mox) | expand

Message

Marek BehĂșn April 24, 2018, 3:21 p.m. UTC
This is the second version of patches for updating the support of Armada 37xx
devices. Here I also send first version of code which adds basic support for the
Turris Mox board, a router currently being developed here at CZ.NIC, which is
being crowdfunded now on Indiegogo.

Changes since v1:
  - these patches were removed, since the update has already been merged into
    U-Boot:
      arm64: mvebu_armada_37xx: Use Armada 37xx pinctrl driver by default
      armada-37xx: Fix SB pinctrl groups according to new revision
  - I have changed the names of the functions SGMIIPHY_ADDR and PHY_ADDR to
    lowercase, as Stefan requested
  - I have used checkpatch on the patches. There still are come warnings, like
    "added, moved or deleted file(s), does MAINTAINERS need updating?" or
    "line over 80 characters" (long string constant in dts). How should I solve
    these?
  - some minor changes based on comments from Stefan
  - added a patch to fix SGMII register addresses
  - added a patch which adds support for the CPU watchdog on Armada 3720
  - added a patch which adds basic support for the Turris Mox board

Please review.

Marek Behun

Comments

Stefan Roese May 14, 2018, 11:54 a.m. UTC | #1
On 24.04.2018 17:21, Marek BehĂșn wrote:
> This is the second version of patches for updating the support of Armada 37xx
> devices. Here I also send first version of code which adds basic support for the
> Turris Mox board, a router currently being developed here at CZ.NIC, which is
> being crowdfunded now on Indiegogo.
> 
> Changes since v1:
>    - these patches were removed, since the update has already been merged into
>      U-Boot:
>        arm64: mvebu_armada_37xx: Use Armada 37xx pinctrl driver by default
>        armada-37xx: Fix SB pinctrl groups according to new revision
>    - I have changed the names of the functions SGMIIPHY_ADDR and PHY_ADDR to
>      lowercase, as Stefan requested
>    - I have used checkpatch on the patches. There still are come warnings, like
>      "added, moved or deleted file(s), does MAINTAINERS need updating?" or
>      "line over 80 characters" (long string constant in dts). How should I solve
>      these?
>    - some minor changes based on comments from Stefan
>    - added a patch to fix SGMII register addresses
>    - added a patch which adds support for the CPU watchdog on Armada 3720
>    - added a patch which adds basic support for the Turris Mox board
> 
> Please review.

Applied to u-boot-marvell/master

Thanks,
Stefan