diff mbox

ObjC: tidy up some comments

Message ID 1294779225.581821604@192.168.4.58
State New
Headers show

Commit Message

Nicola Pero Jan. 11, 2011, 8:53 p.m. UTC
I noticed some comments still referring to the 'copies' and 'ivar' Objective-C
@property attributes, which no longer exist.

Ok to commit ?

Thanks

Comments

Mike Stump Jan. 12, 2011, 12:25 a.m. UTC | #1
On Jan 11, 2011, at 12:53 PM, Nicola Pero wrote:
> I noticed some comments still referring to the 'copies' and 'ivar' Objective-C
> @property attributes, which no longer exist.
> 
> Ok to commit ?

Ok.
diff mbox

Patch

Index: ChangeLog
===================================================================
--- ChangeLog   (revision 168679)
+++ ChangeLog   (working copy)
@@ -1,3 +1,8 @@ 
+2011-01-11  Nicola Pero  <nicola.pero@meta-innovation.com>
+
+       * c-parser.c (c_lex_one_token): Updated and reindented some
+       comments.  No changes in code.
+
 2011-01-11  Richard Henderson  <rth@redhat.com>
 
        * config/mn10300/mn10300.c (mn10300_address_cost): Remove forward
Index: c-parser.c
===================================================================
--- c-parser.c  (revision 168679)
+++ c-parser.c  (working copy)
@@ -253,8 +253,7 @@  c_lex_one_token (c_parser *parser, c_token *token)
                /* We found an Objective-C "pq" keyword (in, out,
                   inout, bycopy, byref, oneway).  They need special
                   care because the interpretation depends on the
-                  context.
-                */
+                  context.  */
                if (parser->objc_pq_context)
                  {
                    token->type = CPP_KEYWORD;
@@ -275,21 +274,19 @@  c_lex_one_token (c_parser *parser, c_token *token)
                       you can't use 'in' as the name of the running
                       variable in a C for loop.  We could potentially
                       try to add code here to disambiguate, but it
-                      seems a reasonable limitation.
-                   */
+                      seems a reasonable limitation.  */
                    token->type = CPP_KEYWORD;
                    token->keyword = rid_code;
                    break;
                  }
                /* Else, "pq" keywords outside of the "pq" context are
                   not keywords, and we fall through to the code for
-                  normal tokens.
-               */
+                  normal tokens.  */
              }
            else if (c_dialect_objc () && OBJC_IS_PATTR_KEYWORD (rid_code))
              {
-               /* We found an Objective-C "property attribute" keyword 
-                  (readonly, copies, getter, setter, ivar). These are 
+               /* We found an Objective-C "property attribute"
+                  keyword (getter, setter, readonly, etc). These are
                   only valid in the property context.  */
                if (parser->objc_property_attr_context)
                  {
@@ -310,8 +307,7 @@  c_lex_one_token (c_parser *parser, c_token *token)
                   protected, public, try, catch, throw) without a
                   preceding '@' sign.  Do nothing and fall through to
                   the code for normal tokens (in C++ we would still
-                  consider the CXX ones keywords, but not in C).
-               */
+                  consider the CXX ones keywords, but not in C).  */
                ;
              }
            else