mbox series

[v4,0/2] Add support for AK5558 ADC

Message ID 1518532174-11350-1-git-send-email-daniel.baluta@nxp.com
Headers show
Series Add support for AK5558 ADC | expand

Message

Daniel Baluta Feb. 13, 2018, 2:29 p.m. UTC
We support normal mode, TDM mode and pm.

Changes since v3: [addressed Mark's comments]
* use C++ comments for SPDX identifier
* removed some unused widgets and controls  (channel enable MUXes, TDM, DSD related stuff)
* removed set_dai_mute, set_bias_level, set_dai_sysclk as they are not used.
* refactored probe/remove to have symmetric operations
* use snd_soc_update_bits instead of hardcode read/write operation.

Changes since v2: [addressed comments from Andy, Fabio and Rob]
* sort include files
* use probe_new
* reword the binding document
* use adc@10 instead of ak5558@10
* remove file name at the beginning of codec source code.
* make i2c_probe and i2c_remove parameters naming consistent.

Changes since v1: [addressed comments from Andy and Fabio]
 * fix GPIO polarity from active high to active low for correct documentation
 * fix license header by using SPDX identifier
 * remove debug prints at the beginning of functions.
 * only support auto clock switching (manual switching was dead code anyway) (in the
   future we could add a DT property to choose between manual and auto)
 * Use gpiod API
 * use GENMASK
 * introduce power_off/power_on


Daniel Baluta (2):
  ASoC: codecs: Add support for AK5558 ADC driver
  ASoC: ak5558: Add bindings for AK5558 ADC

 Documentation/devicetree/bindings/sound/ak5558.txt |  22 ++
 sound/soc/codecs/Kconfig                           |   6 +
 sound/soc/codecs/Makefile                          |   2 +
 sound/soc/codecs/ak5558.c                          | 417 +++++++++++++++++++++
 sound/soc/codecs/ak5558.h                          |  52 +++
 5 files changed, 499 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/sound/ak5558.txt
 create mode 100644 sound/soc/codecs/ak5558.c
 create mode 100644 sound/soc/codecs/ak5558.h

Comments

Mark Brown Feb. 16, 2018, 12:14 p.m. UTC | #1
On Tue, Feb 13, 2018 at 04:29:33PM +0200, Daniel Baluta wrote:

> +++ b/sound/soc/codecs/ak5558.c
> @@ -0,0 +1,417 @@
> +// SPDX-License-Identifier: GPL-2.0
> +/*

Just make this a C++ commment, don't mix C and C++ - it looks neater.
Otherwise this looks good so I'll apply, please send a followup patch
for the above.
Mark Brown Feb. 19, 2018, 5:13 p.m. UTC | #2
On Fri, Feb 16, 2018 at 12:28:21PM +0000, Daniel Baluta wrote:

Please fix your mail client to word wrap within paragraphs at something
substantially less than 80 columns.  Doing this makes your messages much
easier to read and reply to.

> Are you willing to take patches fixing the SPDX identifier for the rest of the codecs in sounc/soc/codecs?
> 
> I've got a bunch of students looking for cleanup patches in their application for Google Summer of Code :).

I guess, though as I keep saying what would be really useful would be
some tooling and automation around this - having to try to keep this
stuff in line manually is very noisy and especially given the divergence
from well established mechanisms for doing things it's not surprising
that people aren't just naturally doing it.